Jump to content
Black Chicken Studios Forums

Neve

Members
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Neve

  • Rank
    Newbie
  1. Oh dear. Will any amount of studying up on how computers work allow me to mod without using the mod tools, then? Ie. Is it even possible to mod without them and, if it is, what is the first thing I want to Google to learn how?
  2. Oh yes, I'm fully aware of how long ago Y1 came out. Pretty sure I got it within its first year or so. Tried to wait for a sale but eventually caved. That's good to know about the official content and Year 2, thanks! I had no idea. All the more reason to figure out how to make a mod for what I want, I guess. Is it still possible to make mods with the current tools? I'm just adding a single new background, so the problems with adventures at least shouldn't affect me.
  3. Alright, so, I decided a few days ago that I was going to make a mod. I downloaded the Mod Tools and the AMO. I opened up the AMO using the Mod Tools and added the new Family background I wanted (one to add 50 background points so they're virtually unlimited -- I'm already using the cheat mod, but I still wanted more :P). I hit "publish mod" and we were on our way! Woot! 14 hours later I had my freshly published mod in hand, and plopped it into the Mods folder alongside the cheat mod and the other two that were already hanging about in there. I started a new game, moved my mod to the bottom of the load order, ticked everything, and went forth only to find that my new background didn't appear. I moved it to the top and tried again. I tried it after Cheat Mod. I tried it in between the two DLC. Nothing worked, so I know load order isn't my issue. I should note, everything else works just fine... it's only my mod that isn't showing its backgrounds, as far as I know (though side note, I recall from playing long ago that there was a "Wands" section in the background, wasn't there? Where did that go? Okay, back to the main issue...) I came back to the forums and read something about never ever changing the AMO, and also about closing and reopening Mod Tools before publishing the mod. I checked, and sure enough, my change had automatically been saved to the AMO. So I removed my change and tried the whole process again. I opened the Mod Tools. I opened the AMO. I added my new background. I saved the mod. I closed the Mod Tools. I believe I also then reopened the AMO, checked to make sure nothing had changed and removed the change again if it automatically saved it (my memory's fuzzy on that bit). I closed the Mod Tools a second time. I opened the Mod Tools. I clicked publish mod and selected the mod I had saved. 14 hours later, I had a new and improved mod, deleted the old one from the Mods folder, and put in my fresh, dazzlingly perfect one in its place. I loaded up the game, clicked start a new game, moved my mod to the bottom of the load order, selected all the mods, and went forth to a perfect future in which my mod functioned flawlessly. Unfortunately, I must have slipped into a different timeline sometime between publishing the mod and getting to the background selection in-game, because my lovely little work of art still didn't function. No new background appeared, no matter the load order... and I tried them all. I sighed, remembered something I read in which someone guessed that based on its size, the Cheat Mod might actually be an official content. Since it has to be loaded before the DLC, this made sense to my little brain, and I decided to repeat the entire process again, but this time convert my unpublished mod to an official content, then publish official content. I think it might have been slightly under 14 hours this time, surprisingly. That or it was longer. I don't know. I fell asleep. I woke up to an awesome official content that was really going to work for real this time. I think you know how this ends. This time, it didn't even show up in game (should I have tried putting it somewhere other than the Mods folder?). So I went to YouTube for modding tutorials, but let's just say there aren't quite as many for Academagia as there are for something like Skyrim. Actually, there were none. Zip. Zero. So here I am, in the one place I figure people might actually be able to assist me. I guess my question is... Help? I figured since I clearly don't know what I'm doing, there's no sense in starting another publishing process without first getting some insight into what the problem might be. Is it not possible to make a mod without the (non-existent?) mod base? If I do need it, where oh where is it hiding? Is there any way I can get a copy of it? And if it is possible without it, what am I doing wrong? Did I mess up the AMO even though I reverted my change to it? I'm running on 4GB of cell data, so I'd rather not redownload it unless I'm sure the AMO is the problem, and as it stands, I have no particular reason to believe it is since I only made one change and then reverted it completely when I learned better. Also, hi. Nice to meet you all. EDIT: I should note, I tried using Cheat Engine instead after attempt #2 failed. And it works, but I found it made the game unstable. I don't know if that makes sense... but that's what happened. I started getting very frequent crashes to desktop in Academagia after using the Cheat Engine tutorial for infinite background points presented elsewhere in this forum.
×