Jump to content
Black Chicken Studios Forums
AlexZ

Adventure action bug

Recommended Posts

Hello,

My game is crashing every time I choose the "adventure" action and click the yellow timepiece icon in the bottom right corner. It crashes before going to the validation screen where I can select the location and which adventure I want to do.

Error message: "Terrible dark magics have collapsed..." the game auto-restarts correctly afterwards, but the bug persists.

Game: Steam version of Academagia (updated).

Mods: both First Touch of Summer and Summer's Blush (yes, I now know that I should have selected only the latter :unsure:)

System: Windows 7

Log (relevant notes start at 28.03.2018): Academagia.log

Save file: exploring.ams

(this bug now occurs in every other save file for this character, including the one made at the very start of the game. When I created a new character with one, and later both, of the mods enabled the game proceeded normally without the above bug)

Notes: The bug began appearing right after the "Dance of Fools" adventure/event. Before validating my actions for the day of the even I had the left character panel open on the the character's skills window. After the event, when I was returned to the day's summary screen the same skills window was open, but it lacked any of the new skills I acquired during the adventure. When I tried to switch to a different panel the game crashed.

I reloaded the game and redid the event exactly as I did previously, but now with the character's attribute window selected in the left panel. The game appeared to work, but since then the above bug appears non-stop.

Please save my character - you are her only hope :)

(edited: date added)

Share this post


Link to post
Share on other sites

If it started affecting previous save files of that specific character than it's more than likely that your cache has gotten corrupted. Delete it and it might fix the bug.

Share this post


Link to post
Share on other sites

The cache is the folder named "Cache_V3"?

It's empty, I've deleted it anyway, but that didn't help and the bug (and the empty folder) reappeared.

Also, in the log files it says:

Quote

[Academagia 3.0.22.0] - [2018-03-28T23:53:28.5844024+02:00] - [Info] - Application start with clear cache.
[Academagia 3.0.22.0] - [2018-03-28T23:53:28.7944024+02:00] - [Info] - Cache is clear.
[Academagia 3.0.22.0] - [2018-03-29T00:01:27.4674024+02:00] - [Info] - System Error. Restarting application C:\Program Files (x86)\Steam\steamapps\common\Academagia The Making of Mages\Academagia.exe with clear cache
[Academagia 3.0.22.0] - [2018-03-29T00:01:27.4744024+02:00] - [Error] - System.NullReferenceException: Object reference not set to an instance of an object.

After every crash. Maybe it's clearing the cache automatically? Or is there a different cache folder?

Share this post


Link to post
Share on other sites

Alex;

Usually when you see that error, it's because of corruption in the save, adding mods mid-playthrough, or by conflicting mods.

Which mods are you using, and do you know if you started with them?

Thanks!

Share this post


Link to post
Share on other sites

Legate,

I'm using both First Touch of Summer and Summer's Blush . I started with those mods and I didn't add any others mid-game (I don't even know how to do that).

Would re-installing help? Or it won't save the character's progress anyway?

Share this post


Link to post
Share on other sites

AlexZ;

You need only one of those- Summer's Blush is the latest. Because they heavily overlap, I bet that's the source of the problem you are facing. :(

The corruption seems to be in the save itself- I don't think reinstalling would do the trick. :(

We'll take a look at the save in further detail, but I don't know if this character can be recovered without the crash.

Share this post


Link to post
Share on other sites

Having had this issue before myself...I'd suggest flat out restarting-a complete reinstall of the game, at least for me did get saves for that character I hadn't opened after the crash working again, but they tend to just corrupt again at a later point since you can't really change mods mid-playthrough and I imagine import into year 2 would prove extremely dodgy when the time comes, even if you successfully got through year 1.

Share this post


Link to post
Share on other sites

Thank you very much for your replies! I didn't check in advance if the two mods clash and now I learned the hard way.

I'll restart my character since I've already opened all of her previous save files, so they're all corrupted. It's a pity - I got quite attached to her.

I guess it speaks volumes on the emotional quality of this game if I get so attached to a fictional character :)

 

BTW, since this problem happened to me and Kanarena, maybe it would be best to add a note somewhere on the Steam page (like at the head of each update so it would be seen from the main page) that players should only choose the Summer's Blush mod?

Edit: the current page says that the new DLC is The First Touch of Summer, which is confusing.

Share this post


Link to post
Share on other sites

I got this bug and was only using Summer's Blush. I strongly suspect that it has to do with Academagia Practice Room #4, because both times this bug has occurred to me (separate characters, separate caches, et cetera) has been after I used that action. But not after the first time I used that action, you understand, just at some point after I used the action.

Share this post


Link to post
Share on other sites

Riidi:

I my case restarting with the latest DLC solved the problem and I haven't seen the bug since. With me it wasn't connected to Academagia Practice Room #4 because my character never went there.

Share this post


Link to post
Share on other sites

Which is just summer's blush? Some people on steam said it was connected to moving UI elements during load so i'm restarting and locking the UI. Probably going to drop Music so im not tempted to use the practice room too, lol.

Share this post


Link to post
Share on other sites

Happened again to me, not related to practice room #4 this time. It happened just after I raised my finesse to 10 with assist the master, could it have something to do with attributes hitting 10?

Share this post


Link to post
Share on other sites

After it happened to me I deleted the save, deleted my cache, and restarted my computer, and the corruption still reached backward in time to corrupt a save of that character I know was working previously.

Share this post


Link to post
Share on other sites

Weird. But it's not related to level 10 either, since none of my attribute were level 10. It's either we have different bugs that look the same, or your mod is somehow corrupted.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×