Jump to content
Black Chicken Studios Forums
Academagia Fan

Troubleshooting

Recommended Posts

thank u all for ur help i finally got it to work.. i just now need to get how to play the game.. ill just go wiki it and see what the deal is..

 

 

thanks again :)

Share this post


Link to post
Share on other sites

Hiya - I'm on Win7 32bit, bought the game on Impulse - have installed the latest consolidated patch (26, I think), but when I try to start a new game, I still get the error. What other info might you need from me?

Share this post


Link to post
Share on other sites

Mikeside;

 

The problem is almost certainly related to UAC. There are two troubleshooting steps to try, starting with the easiest:

 

1) Navigate to your Academagia folder, right click on Academagia.exe and choose: 'Run as Administrator'.

 

...that will usually solve the issue. If that does not work, there's a peculiar issue with overwriting the game's files that we haven't been able to exorcise. What you will want to try next is this:

 

1) Navigate to your Academagia folder and delete all the files and folders which correspond to the ones in the latest Patch. The important ones are:

 

Mods (folder)

Academagia.Core.dll

Academagia.exe

Academagia.UI.dll

Common.dll

ContentModel.dll

GameLogic.dll

Storage.dll

 

2) Once you have deleted these, drag the files and folders from the latest Patch and put them in the same place as the files and folders which you deleted. Be sure *not* to overwrite- you must delete the current ones first, and then replace them with the new ones from the Patch

 

...after this, there should be no further issue.

 

If that does not solve the problem, please let me know, and thanks!

Share this post


Link to post
Share on other sites

Mikeside;

 

The problem is almost certainly related to UAC. There are two troubleshooting steps to try, starting with the easiest:

 

1) Navigate to your Academagia folder, right click on Academagia.exe and choose: 'Run as Administrator'.

 

...that will usually solve the issue. If that does not work, there's a peculiar issue with overwriting the game's files that we haven't been able to exorcise. What you will want to try next is this:

 

1) Navigate to your Academagia folder and delete all the files and folders which correspond to the ones in the latest Patch. The important ones are:

 

Mods (folder)

Academagia.Core.dll

Academagia.exe

Academagia.UI.dll

Common.dll

ContentModel.dll

GameLogic.dll

Storage.dll

 

2) Once you have deleted these, drag the files and folders from the latest Patch and put them in the same place as the files and folders which you deleted. Be sure *not* to overwrite- you must delete the current ones first, and then replace them with the new ones from the Patch

 

...after this, there should be no further issue.

 

If that does not solve the problem, please let me know, and thanks!

 

Yep, tried all that with no results :( I don't know if this is relevant - but when I try to run RunElevated.exe, I get an error saying "running directory must not end with a backslash" - don't know if that is any help?

Share this post


Link to post
Share on other sites

I've just tried the latest DLC and it won't load under Windows 7 64-bit. The normal content loads and runs, but the DLC won't load.

 

I've made the application 'Run As Administrator' and I've right clicked and run it was administrator.

 

If I try to load the DLC Hope's Shield Endures, I get two application crash popups:

 

System error occured. Application will be terminated.

 

One after the other, then it application closes down.

 

I have been able to load DLC's in the past, so I don't know what changed after the patches. I haven't played in a bit, but wanted to try the new content and can not.

Share this post


Link to post
Share on other sites

Tobin;

 

This kind of a problem is usually related to UAC. The easiest way to solve is to take the following steps:

 

1) Navigate to your Academagia folder and delete all the files and folders which correspond to the ones in the Patch. The important ones are:

 

Mods (This is a Folder)

Academagia.Core.dll

Academagia.exe

Academagia.UI.dll

Common.dll

ContentModel.dll

GameLogic.dll

Storage.dll

 

2) Move the files and folders from the Patch into your Academagia directory, so that they occupy the same place as the ones you just deleted. Note that it is very important that you delete, not overwrite!

 

...after this, you should be able to play without UAC issues.

 

Let me know if you have any further problem!

Share this post


Link to post
Share on other sites

I followed all those steps. I removed each file and directory in the patch. I then moved the files and directory from the patch directly into the program directory. Runs fine w/o the DLC. Crashes immediately with those two errors when I try to load the DLC under Windows 7 64-bit. I got the program off of Impulse and it is installed in "C:\Program Files (x86)\Indie Games\Academagia - The Making of Mages". I looked for a log file in the C: drive. None was created. I even took the step of re-enabling UAC (which I hate and disable immediately), rebooted my computer and started the game again. It doesn't appear to be an elevation problem since I get no elevation prompts (and I had UAC disabled to start with).

Share this post


Link to post
Share on other sites

Tobin;

 

Very strange! Our primary test environment is 7 x64, and we haven't seen anything like this at all.

 

Just to confirm one thing:

 

"I removed each file and directory in the patch. I then moved the files and directory from the patch directly into the program directory."

 

...did you first delete the files and directory in your Academagia folder corresponding to the ones in the Patch prior to moving them into your Academagia folder? It's very important that you do not overwrite those files- they should be entirely gone.

 

Now, for the next step- I note that the game runs fine without the DLC. One possibility for this is that you played, at some point, a very old version of the game. Some early versions had problems with their caching, and this leads to similar results as you have experienced. Is it possible that you played another version of the game prior to your purchase from Impulse? If so, we can discuss the steps necessary to correct that issue as the next step.

 

Let me know, and thanks!

Share this post


Link to post
Share on other sites

Yes, I removed each file from the program directory as directed. And yes, I have no problem playing the game if I don't try to load the DLC. It crashes immediately when I try to load the DLC (after I check it and click on the next button). I have also tried to uninstalled and reinstalled the game straight from Impulse too. The new version downloaded from Impulse has the same problem if I try to run it.

Share this post


Link to post
Share on other sites

Tobin;

 

Extremely strange!

 

Let's move on to your cache. You will want to navigate to:

 

C:\ProgramData\Academagia and delete the 'Cache' folder you find there, if any.

 

Next, inside the Patch you will find a utility called AMTempFilesCleaner.exe. Please run this.

 

Once you have completed both steps, delete the GCC folder from your Academagia\Mods folder.

 

Finally, please run the game as Administrator and see if you are able to use the DLC.

 

Let me know, and thanks!

Share this post


Link to post
Share on other sites

That did it. Thank you so much for your help. FYI - I did have a Cache directory. Runs fine now. I'll make sure I check that the next time I patch and have this problem. You probably should recommend that your devs put together a patch program to clean up all these files as part of your updates that come down with Impulse too since I'm sure that this problem will happen in a future DLC.

Share this post


Link to post
Share on other sites

The problems you haved are only if you once have runned Academagia with a very, very old version that you cant get anymore.

Share this post


Link to post
Share on other sites

Legate, if you remember, a few months ago I had the same problem when I updated to Patch 28 (like Tobin's, but you PM'd me about it instead). Recently I updated to the latest consolidated patch, and had the same issue after I played the game twice with no problems (leading me to believe the Vista issue back when I last visited was fixed... =P). HOWEVER, this time, neither of the three steps worked! I tried downloading the patch again and recopying it again and again, reinstalled .NET 3.5 SP1, restarted windows... To no avail. I did exactly what you told me last time as well (numerous times), but each time I started there were issues with loading previous saved games. Funnily enough, I can still create a new game (I haven't tried to save it so I'm not sure what's wrong).

 

*utterly confused*

Share this post


Link to post
Share on other sites

Scheherazade Empress;

 

I don't recall off hand the particulars of our previous discussion, but my guess is that if you cannot load an old save game, it is probably an issue with the cache. I noticed that you wrote about the three steps- are these the ones, below?

 

To resolve that, you'll need to navigate to C:\ProgramData\Academagia and delete the Cache folder you'll find inside, if any. Note that that folder is a hidden one, and you may need to turn options on to view it.

 

Next, you will want to run the utility AMTempFilesCleaner.exe, which can be found in the Patch.

 

Finally, you will want to navigate to your Academagia\Mods directory and delete the GCC folder inside, if any.

 

Assuming my intuition is correct, that should enable you to load your old saves. :)

 

Let me know!

Share this post


Link to post
Share on other sites

SE;

 

Got it! Another reason this might be occurring is if Academagia does not have the rights to access those folders. You should try running the application as Administrator- you can do this most easily by navigating to your Academagia folder, right-clicking on Academagia.exe and selecting 'Run as Administrator'. That may clear up the problem.

 

Let me know, and thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×