Jump to content
Black Chicken Studios Forums
Sign in to follow this  
Legate of Mineta

Update on Vista Save Game Corruption Issue

Recommended Posts

Vista users:

 

There is a bug which can arise in certain setups of Vista which causes the saving function in Academagia to break. When this happens, you will be unable to save, and if you try to overwrite a good game, it will destroy the save.

 

This issue *appears* to be related to .NET 4.0 Client Profile, which is a 'light' version of the .NET framework, and seems to impede the functioning of the .NET components Academagia relies on to save. Although Academagia supports .NET 3.5 SP1, we are attempting to solve the issue for this specific version of .NET 4.0.

 

In the mean time, there are three possible workarounds:

 

1) Uninstall .NET 4. If you already have .NET 3.5 SP1 installed, this is the closest to the base requirements of the game, and should solve the issue if our guess is right.

 

2) Uninstall .NET 4 Client Profile and replace it with the standalone installation of .NET 4 (http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=0a391abd-25c1-4fc0-919f-b21f31ab88b7) Again, if you already have .NET 3.5 SP1 installed, this should solve the issue if our guess is correct.

 

3) Save your game, always using New Saves, every week or so. This will minimize the impact on your gameplay if you do experience the bug.

 

If you experience this bug, and can provide any additional information, please let me know, and thanks!

Share this post


Link to post
Share on other sites

Just FYI, my machine has .Net 3.5 SP1, and I had uninstalled .NET4 Client Profile (I actually Need .Net 3.5. For work.)

 

Saves fine for me.

Share this post


Link to post
Share on other sites

Imperii;

 

It is intermittent, and this is the reason why it is so difficult to close on our end.

 

A question about your system: do you have any version of .NET 4.0 installed? Also, for your next saves, please run Academagia by right-clicking Academagia.exe and selecting Run as Administrator.

 

Thanks, and please let me know.

Share this post


Link to post
Share on other sites

It looks like I've had this issue, too, after several hours of playing. I've got Vista, and I think I have .NET version 4. I don't have any other version of .net installed.

I will try starting the program as "administrator." Before the patch, I also had a problem where the game simply would not launch, but at least that problem has resolved!

Share this post


Link to post
Share on other sites

largemarge;

 

Please give us any updates on the success of running as Administrator and/or the two workarounds listed at the top of the page. We still have not been able to replicate this error, and will greatly appreciate any feedback here!

 

Thanks!

Share this post


Link to post
Share on other sites

I also have this problem, but it doesn't occur very often; it's happened to me three times. Each time, it was at least midway through the game - it never happened before midterms.

 

I tried the fresh installation of .Net 4, but it happened again after that, so it didn't fix it for me. I've been saving it every week in a different slot (I was varying between two slots); I was also saving it right before adventures. The last time it happened, was when I had saved it for an adventure, and then went to reload it - that save was gone. The previous save had been the day before, so I loaded it. Anytime I tried to save with that one, however, it suffered from the same issue. The saves were only a day apart, and while the first one was good, any later ones from that one were corrupted.

 

I'm trying the running as an admin now, and I'll see if this pops up again.

Share this post


Link to post
Share on other sites

Well, apparently I spoke too soon. Strangely, the two most recent save game files have now disappeared, but older files are stll there and everything works fine. Is there a maximum number of save files the program allows? I think I'm up to 15 separate files (and yesterday probably had 17).

 

Is it possible to manually back up a save file? Somehow I'm guessing it's not that simple.

I'm enjoying the game, despite the Vista snafu.

-largemarge

Share this post


Link to post
Share on other sites

largemarge;

 

It is possible to manually back up a file- you'll just need to navigate down to where saves are stored (Schwarzbart's link will show you where.)

 

We are still testing the issue, although we have not yet been able to replicate it. If you come across a situation as Aletea did, where you have a save which you can load fine from, but all future saves are corrupted, please let me know immediately. We are very interested to see that save. ;)

Share this post


Link to post
Share on other sites

For those Academagians experiencing the save game issue on Vista, please play until you experience the issue, and then send us AcademagiaInfo.log which will be present in C:\ProgramData\Academagia. Additionally, you may see a pop-up request while playing the game, requesting that you send us certain files. Please do so as soon as you are able.

 

This reporting will not correct the issue, but will enable us to hopefully locate it. To date, we have not been able to replicate this issue.

 

Thanks!

Share this post


Link to post
Share on other sites

I've just had this problem. I'm not sure where my log file is though. I got the game through Impulse and there's no folder named ProgramData directly under my C: drive. I've found the academagica install (confusingly impulse puts it under program files/indie games) but it does not appear to have a log file.

 

If you let me know where to look, I may be able to check the forum and send a log file. I don't want to make any promises though - I'm going to put this game aside for a time now, so if you don't hear from me it's because I've not been reading the forums.

Share this post


Link to post
Share on other sites

Something a bit unusual just occurred. I had continued playing on a save file that was corrupted (it's the file I sent you the other day, Legate); I wanted to keep going with it, so I just minimized the game and left it running. I continued playing it today, and after two in-game months I decided to try to saving, just to check - and it saved properly.

 

This is a save file that, when I attempted to save it right after it's previous saves, would only create corrupted files. But with leaving the game running all night, or the in-game time itself, it suddenly isn't corrupting the save files.

 

Here is that save file ;)

 

http://rapidshare.com/files/423327614/Dean.ams

Share this post


Link to post
Share on other sites

Aletea;

 

Thanks! With your help and another Academagian's save, we've been able to isolate the issue. The problem is that it is occurring in a Microsoft component which...should not fail. The why of it is still eluding us. In a few weeks we will have another report and/or standalone application which we may ask you to run, but hopefully we will be able to solve it before then.

 

Thanks again!

Share this post


Link to post
Share on other sites

I am posting this here because this has only happen since i uninstalled .NET 4.0 Client Profile as per the work around to the save game Corruption. Since uninstalling .NET 4.0 Client Profile i have had 2 seemingly totally random application errors causing crashes to deaktop that i don't know the cause of and was wondering if any one else has had this problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...