Jump to content
Black Chicken Studios Forums
Sign in to follow this  
Legate of Mineta

Update on Vista Save Game Corruption Issue

Recommended Posts

I think I've just today finally ran afoul of this bug. I doublechecked this thread and It's a bit different from what's described here though...

 

I created a new character today for a new attempt for a better Y2 char. I haven't played the game in a while, but right away I noticed something was off as the popup for actions was half off screen. Fearing the worst I decided to save to make sure I wasn't going to lose progress and then.... as soon as I hit the save button the whole game froze. I had to control-alt-delete to close it, but task manager reported that curiously the game was still running (IE. It didn't have the "Not Responding" flag.)

 

I reinstalled the game and updated my PC but to no avail. (Also I noticed impulse has not kept up with any patches, just fyi)

 

I suspect the reason for the difference is because of what you did with the last patches to minimize it. Anyway if this is the same bug at least we don't have to worry about it corrupting any saves because it won't let you get that far. :lol:

Share this post


Link to post
Share on other sites

Hmmm- if your pop-ups are off the screen, then the issue may be related to your visual settings. What you'll need to do is navigate to your Display settings and make your text size to 100% (small), which is the default.

 

After that, you should have no further problems. :)

Share this post


Link to post
Share on other sites

Actually, It turns out it WAS a display issue. Though not quite as predicted. The game's display text size was at it's default level.

 

 

As it turns out, since the last time I'd played, I had increased my display resolution as far as it goes. Well, standard text at that resolution is quite small so I tripled the standard windows text display size. Apparently Academagia uses whatever windows setting for font size is and modifies it at that point, so 100% default game text size is apparently too big if windows text size itself is too big.

 

Oh and it saves just fine. False alarm. :)

Share this post


Link to post
Share on other sites

HAI THERE Y'ALL!

 

It's been a while, I must say, and I hate to be the bearer of bad news, but... I still have this problem. Patch up to date and everything. Uninstalled the .NET4 and reinstalled the standalone, but when I tried to save, I couldn't. I wasn't using the selective focus modifier; I was Studying at the Library of Longshade, Visiting Sabinu's Grotto and Adventuring. It was jarring because I was able to save one day, and the next (after I finished adventuring), I couldn't.

Share this post


Link to post
Share on other sites

SE;

 

On the contrary, *we* hate to be the bearer of bad news: we've not been able to correct the issue. :(

 

It seems to be related to Training Modifier, but the problem likes in a MS component that we do not have visibility in.

 

Still, we are tinkering away it!

Share this post


Link to post
Share on other sites

Say Legate, This nasty bug is limited only to Vista, yes?

 

I'm considering upgrading my PC, and want to make sure that I don't break the game in the process.

 

I've finally gotten the courage to test Win7, and am surprised that it was possible (though difficult) to tame. Given the similarities between Vista and 7 I don't think it hurts to ask.

Share this post


Link to post
Share on other sites

Ah, Legate, I am curious what the known status of this most evil bug currently is and what (if anything) you are planning to do with it. I re-read this thread and was curious if you were still interested in log files as I recently bumped into this problem.

 

No serious loss as I was saving almost every day with two alternating saves because, well, I was interested in seeing what I could do if I skipped some classes. (And I knew I was running Vista so I braced for it.) In my case I can state for sure it happened after I used selective focus. albeit not immediately. more like a few days after the effects should have ended.

Share this post


Link to post
Share on other sites

That's a shame. Are you planning on locking out vista users from using Y2, then? Personally I think it's annoying but not an 'end-of-the-world' scenario.

 

I've been doing some experimenting with it now. I can tell you that I've tried loading known good saves while experiencing it and while I can do so, no saves from this file are successful. It may not mean much but that leads me to believe that whatever causes it is tied to data that the game doesn't load if there is already a game in motion (like college portrait data et cetera)

 

I also managed to trigger it without using any training modifer abilities since starting the program (lthough it was still there when I loaded an old save.) Is there a console command I can tinker with? This is probably the first time I've actually encountered the bug, so I'm fired up in wanting to help. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...