Jump to content
Black Chicken Studios Forums

Patch 34 Bugs


Recommended Posts

My Health got to 22 at the start day (max is 4) but its not a display bug because I keep the Vitality point even after I got damaged in a Adventure (I ended up with 19 Vitality then with still 4 max).

This can be simply reproduced from a New Durand char with the Professor Briardi's Address Adventure


Edit: No bug but its strange that all 3 starting Durand Adventures direct start with the Regent of Durand.

As if there is not enough stuff for adventures with the study of Botany as one of the central Class skills of this college.

Link to comment
Share on other sites

  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Not sure if this is a bug, but when selecting the adventure "Alan's Tale", it shows up as red in the selection list. Going on the adventure gives three options: one is green (the automatic failure exit), and the other two (success) are purple. It was my understanding that the failure exit wouldn't be considered in the colour coding, so shouldn't this adventure show as purple in the list?

Link to comment
Share on other sites

All of these bugs are from patch 33, actually. But there's no patch 33 thread, and none of them involved equipment, so... I guess I'll put them here? It seems okay to do. All of them are DLC type bugs, though, so not all that helpful.



* The Genealoogy Project, M Mhadi’s adventure, needs only one o.

* Love in the Waves, by Grelda Mannist III (‘…hoping he’d return, saying he changed his mind and live withe forever.’)- I think it should be 'with me'.

* Elemental Warriors 07 – on page seven, there’s a ‘You love love you and see the lake splitting apart’- love should be look. There’s also mention about you serving on the Cyve, then a mention of the Gaia taking off, then the ship you're on is flying but you're on the Cyre. Not sure if the Gaia is supposed to be the Cyre, or if there should be a mention about the Cyre and other ships following the Gaia- either would make a bit more sense.

* the Cutlass (an Elemental Warrior adventure), Major Aqua says “Ah it’s the new guy!” – a coma is needed after ‘Ah,’ and as only one character is being addressed, either a gender appropriate 'girl' should be used or the character should have an option to correct or scowl at him, because in my experience, for girls that age, not being called 'boy' or 'guy' is a big deal of incredible offensiveness.



* There's a picture that's used on Holiday [The Theneia] and a bunch of others (I believe for the dance events, too)- it’s the one of the great hall, with the checkered floor and a bunch of students standing on it, with pillars that have purple lights strung around them and between them. Every time I've seen it, it's clipped the first line of story for each page unlike every other picture. I use 1920x1080, if that's of any help.

* Hunting for Shoes, Katja's adventure- I followed the Composure exit, which implied my character stole the magic of thief. No Iron Boots appeared in the inventory (the reward was +2 composure skill step), however (as I know they do if you do the Negotiation exit), and Katja’s adventure simply disappeared from my Adventure list never to be seen again.

* Sheets of Ice may or may not be be hitting the opposing clique, but I know it hits my character- they end up shivering and with a stress point each time I've tried it.

* Katja apparently succeeded on using Reflect on Merit on Durand’s Vincent Warrender, and Silke managed to Reflect on Merit with Avila's Cyrus. I think they’re all a bit confused.

* Observation gained me Manelia’s Shack, and training there one day gave me Manelia’s Pond. The Pond showed up in locations, and it appeared in my left sidebar at the appropriate place in the Abilities and Actions screen. It was also announced in the Events Important To You area. However, it never appears when you click on a day to choose what you want to do- it's just not there. It seems to either not be linked, or it has a hidden requirement that isn't listed.


Just things to poke at:

* It seems if you get access to the Gorthinak’s Personal Workstation through the event (Random Event Forge 8- Incantation success, for me), you should get full visitation rights as well. (Maybe you do, but it’s not noted- it just says you have learned about it and you have added it to yourself: if that's true, then I simply think it should be noted.) Once you've been invited by the Grand-Smith to come whenever you need to, it seems wrong that you'd be kicked out, and there's a huge discovery chance at that location.

* Like a Rock (Silke’s adventure) seemed a bit weird when the statues that were riddle statues that had nothing to do with fashion went chasing after people trying to change their clothing for them. Just a mention that the fashion mirrors had managed to influence the statues would help the story make more sense- then it would work whether your statues were fashion statues, mimic statues, riddle statues, or flying kitty statues.

* Cat Bond Adventure is just really messy. The story is good, but the execution of when the adventure is broken up has a difficult time table. It starts around Cat Bond Adventure 5, where you follow the thieves around to the tavern, where you can’t hear them because of a flute player, and then you fix that (or fail and retry). Adventure end. But Cat Bond Adventure 6 starts with you still in the tavern listening to the thieves. It seems hearing the evil plot would better be at the end of Cat Bond 5, and Cat Bond 6 could then just be 'I need to go save the apprentice!', starting with the encounter with the robber. There's also that then, Cat Bond 6, you heard the tavern plot and know that the letter will be found at nightfall and the Apprentice is going to be in huge trouble that very night- but oops, defeat the robber, adventure end. The encounter with the apprentice and the bookkeeper attempting to fire him (Cat Bond 7, I persume) really needs to fire immediately after Cat Bond 6 if you succeeded, or else your character looks like gigantic jerk (Meh, I rolled past a robber. My work for the night is done. Who cares about firing? Bother me later.)- if not that, then the time table needs revision. The same thing happens later on, though I was too stupid to get the numbers exactly (I'm sorry!). In it, you go to scout out the Pirate Ship, and you notice the Apprentice has been kidnapped AND the ship is going to sail away that very night! Oh no! So you figure out a way to get yourself on the ship- then, boom, adventure end. You have to wait till the next day to start the adventure where you're on the ship with the apprentice saving him from the ship that was going to sail away the night before, really. There's a lot of abstracted time in Academagia by necessary (the villain will always still be there if you fail an adventure for you to attempt it again), but this adventure seems to constantly make use of time tables but then make them simply impossible to follow. There seems to be no downtime between events, but if that's so, it should be continuous until failure or downtime occurs to then, rather then assuming no downtime when there very obviously is some forced.


...I wonder if that made any sense at all.


And as shops came up, a shop information tab (or even a section about shops under the lores in the right) would be excellent for DLC8 and it's focus on the city, as right now you can't relook over shops to see what each one sells very easily (if at all). It's my only big UI/lack of information thing left in the game. Just hoping. ;)



Oh, I forgot one- Dueling! Break the Dueling Circle should really, really have a description to it. It would be nice if pace and salute and such did, too, but break the dueling circle is the big one.

Link to comment
Share on other sites

The Lightning Pheme doesn't do anything. It appears to add difficulty and an Expand (-1) Vitality effect to the list, but it never does the point of damage it's supposed to.


Also, I've reached a point where my current game crashes to desktop with a system error. It doesn't appear to be linked to choices I make that day; just resting still results in a crash. I've sent a PM with a link to the saved game file.

Link to comment
Share on other sites



A quick test seems to show that the -1 Vitality does apply correctly- it's contingent on the Target of the Spell you are adding it to, and expects a single Character. Can you clarify which Spell you are adding this Pheme to, and which Target that Spell has?


For save, you have anticipated me- thanks! We'll have a look at this in the coming week.


Edit: Confirmed. We see the crash, although not yet why. Thanks again!

Link to comment
Share on other sites

The spell was Wrath of the Comet's Tail, with two Lightning Phemes. The Target was Philippe Marchant. I know I cast it on him successfully--I got the success feedback and saw that he had taken damage--but it only said it did 4 points (from the base spell) and didn't say or show extra damage from the Lightning. I tried it another time, same thing happened.

Link to comment
Share on other sites

Okay, so I'm not sure exactly what's been going on. I increased my max Character Study by 1 by getting Listen to 10. I then trained Character Study to 11. After this, sometimes the left side panel would show the skill as 11, sometimes as 10, but it always said it was at its maximum. Then something (I think it was passing the Character Study test to get into the Last Feast during that holiday event) said I increased my Character Study by 2 (which shouldn't have been possible, since I was at my max) and that I gained Character Insight (which should give me +1 Insight).


Now the Character Study Subskill has me at 11, but says I have 0 of 2 steps needed for the next level, rather than saying I'm at my max. Training Character Study does nothing. Also Character Insight doesn't appear to work at all, i.e. it gives no bonus to my Insight.

Link to comment
Share on other sites

There's a loop and an error of some kind in The Topiary Garden Adventure. I ended up juggling between The Topiary Garden and Leaving The Topiary Garden, then got stuck doing the same loop (the one that gives you the stone key) again and again, even though I passed it. When I finally decided to fail the adventure, I went back to it later and got a description but no options. I was told that I passed that adventure again, and then the entire adventure chain was removed from my list.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...