Jump to content
Black Chicken Studios Forums

Patch for 3.0.8 (for those who downloaded 3.0.6 from BMT)


Command
 Share

Recommended Posts

Schwarzbart, you know what needs to be done! ;)

 

As soon as there's an opportunity we find a way to patch DLC 17 into pre-steam versions!

 

There shouldn't be an issue with Y2 on that, right legate!?

Link to comment
Share on other sites

 Share

×
×
  • Create New...