Jump to content
Black Chicken Studios Forums

Steam initialization failed [resolved]


Recommended Posts

Just purchased and installed Academagia on steam. When launching, UAC requests admin permissions. After I (begrudgingly) grant admin permissions, the game fails to launch with the following message:


"Steam initialization failed. Application will be terminated."


I've verified the integrity of the game cache. (no problems found)

I've restarted the PC.

I've tried reinstalling the game. (issue still persists)


OS: Windows 10 Pro x64

CPU: AMD Phenom II X4 980 Processor, 3.70 GHz

RAM: 16 GB

GPU: two NVIDIA GeForce GTX 960s in SLI configuration.

Link to comment
Share on other sites

No, I have many many games on steam. No real info to add. I checked the Academagia log (C:\ProgramData\Academagia\Academagia.log), and it really doesn't tell anything new/useful.


[Academagia] - [2017-04-20T23:30:06.4292002-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-20T23:30:29.4635485-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-20T23:32:25.2779061-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-20T23:39:42.6632513-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-20T23:45:24.4204205-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-20T23:45:41.7566157-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-21T00:00:15.2262157-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-21T00:01:13.9809479-05:00] - [info] - Steam initialization failed.
[Academagia] - [2017-04-21T00:09:18.4677731-05:00] - [info] - Steam initialization failed.
There's also nothing else in that folder. No cache to clear or anything.
If it matters at all, I've got my Steam installed in a custom directory (not the program files directory).
Link to comment
Share on other sites

Ok - what happens when you try to start the game outside of Steam? Trying to see if it's related to achievements. That's the only thing that needs to be initialized I think.


If it works outside, then it's def the Steam app.


Edit: Found this .... https://steamcommunity.com/app/298630/discussions/1/364042262880299818/

Let us know if the instructions in that thread work for Academagia.exe

Link to comment
Share on other sites

Tried running the game directly via .exe as administrator. Same error.


Installed the Visual C++ Redist 2008 (x86) package.

Shut down steam, restarted pc, launched steam.


Tried running the game again, both through the steam client, and via .exe as administrator. Still the same error.

Link to comment
Share on other sites

Update - our dev team has isolated the section of code that generates the error (coming from the steam dll). We are contacting their support as we do not understand the reasons why. So unfortunately, at this point, does not seem to be a quick fix.

Link to comment
Share on other sites

This just in from our developer...



I read almost all forum about SteamAPI_Init(). This error occured in other many applications not only our. This error normally should only happen when there are files missing. The base recommendation are below:


1) Go to your Steam folder and delete appcache

2) Close steam, run it as admin again. (restart steam as admin)

3) Try: disable antivirus and install VC REDIST 2012 (x86 and x64) from Microsoft website??? I think it is optional requrement because if other games are works it means dlls and antivirus ok.


Often users after it have working system but sometime not =(


This is one post from forum:


Because the steamapi error has come up in countless forums and not just GITS. This isn't a game error or bug it's an issue with your steam client and steam trying to run the game.


We still only have this one report of it happening...but let us know if you decide to try this and the results. Hopefully clearing the Steam appcache will resolve it.

Link to comment
Share on other sites

Well, that seems to have fixed the issue. I was able to run the game after clearing the cache and running steam in admin mode. (I did not perform the third step.)


After that, I decided to restart steam again in regular (non-admin) mode to see if the game would still run. I got the same error as before.


In short, I can't say whether or not resetting the cache made any difference, but it seems I must have steam running in admin mode in order to play this game. While I generally trust the steam client to not do anything malicious, I have to say I do not like the additional security hole that comes with providing steam full admin privileges. This is the only game I have (out of many) that has required this in order to work. This makes me very uncomfortable, but I suppose it'll have to do.


Thank you for your support.

Link to comment
Share on other sites

Glad it worked out. If you want a version without the Steam wrapper (so you don't have to run Steam in admin mode) contact academagia @ gmail . com.

Of course you would still have to run Academagia in admin mode, but that would be one less thing. No achievements though.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...